[RPA機能]-[認識結果を入力する]で、入力できなかったり文字化けを起こしたりする

原因

[RPA機能]の[認識結果を入力する]アクションで、送信項目や送信先により、入力できなかったり文字化けを起こしたりすることがあります。
入力先のアプリケーションの仕様や文字種(半角カタカナ)により、これら事象が発生します。

また、転記先の入力欄のIMEがONになっている時に再変換されて、次の[ENTER]押下が移動ではなく変換確定になり、望まない文字に変換されてしまうこともあります。この対策についても併せてご紹介します。

対策

ワークフロー作成時、[認識結果を入力する]アクション(AI JIMY バージョン 3.0.8 以降)の[□クリップボード経由]にチェックを入れることで解消されることがあるので、お試しください。
[□クリップボード経由]にチェックを入れると、文字認識結果を一旦クリップボードに保存し、入力対象に貼り付けます。
そのため、クリップボード上に直近の入力結果が残ることにご留意ください。
なお、システムの仕様上、クリップボードの履歴を削除することにご留意ください。

また、IMEがONになるために問題が生じている時は、ワークフロー作成時、[IMEを切り替える]アクション(AI JIMY バージョン 3.0.10 以降)でOFFを選択することで、強制的にIMEをOFFにすることが出来ます。
転記先のアプリケーションの仕様により、入力欄にフォーカスを入れるたびにIMEがONになる事がありますが、その時は毎回[IMEを切り替える]アクションを呼び出してください。
なお、[IMEを切り替える]アクションでIMEをOFFにしなくても、[□クリップボード経由]にすることで転記出来ることもありますので、お試しください。

それでも貼り付けが行われない

[□クリップボード経由]にチェックを入れると、動作環境により(処理が早すぎて)貼り付けが間に合わなくなることがあります。
その場合は、[認識結果を入力する]の前後に[待機する]を挟むことで、クリップボードから貼り付けに必要な時間を確保してください。
また、[☑ENTER]または[☑TAB]にチェックを入れている時はチェックを外し、[待機する]アクションの後で[キーを送信する]アクションの[{enter}]または[{tab}]に分割することで、動作が改善する可能性があります。

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